» » » Kunena 2.0.4 - компонент форума для Joomla

Kunena 2.0.4 - компонент форума для Joomla

0
Kunena 2.0.4 - компонент форума для Joomla

Kunena - это коммуникационная платформа для Joomla. На сегодня Кунена (компонент форума) является идеальным - форумом для Joomla. Это бесплатное расширение, которое полностью интегрируется в Joomla, при этом никаких мостов и хаков не требуется.

Компонент Kunena 2.x работает с использованием библиотеки MooTools которая входит в стандартный дистрибутив Joomla 1.5.26 и Joomla 2.5.3+. К тому же вы должны убедится, что ваш шаблон Joomla поддерживает последнюю версию MooTools. В основном, все шаблоны Joomla 2.5 должны быть основаны на MooTools и многие шаблоны созданные после 2010 года (для Joomla 1.5) совместимы с этой версией.

Прежде чем устанавливать компонент форума Kunena 2.x убедитесь, что его технические требования соответствуют Вашему серверу, так как технические требования Kunena 2.0.+ отличаются от тех. требований самой Joomla и предыдущих версий Kunena. Это связано с тем, что новая Кунена 2.0 может работать на сайте с тысячами активных пользователей и содержать миллионы сообщений.

Минимальные системные требования:
- PHP 5.2.3+ или 5.3.0+
- MySQL 5.0.3+ или 5.1.0+ или 5.5.0+
- Joomla 1.5.26 пакет или 2.5.4+

Получается, что для работы Кунена требуется PHP 5.2.4 и выше.

Хотя PHP 5.2 и поддерживается, рекомендуется использовать последнюю стабильную версию PHP 5.3 или PHP 5.4.

Установка компонента и русификация компонента.
Компонент Kunena устанавливается как обычное расширение и в принципе там нет ничего сложного. Единственное, что нужно отметить, это только то, что лучше всего первым делом установить языковый пакет, который находится в архиве с компонентом.

К примеру, для русского языка - это будет файл из папки:
папка: Kunena 2.x Extensions,
файл архива: pkg_kunena_languages_v2.0.4_2013-01-18.zip
файл русского языка: com_kunena_ru-RU_v2.0.4.zip.

Вот в принципе и все, что можно отметить, русский язык установлен теперь можно устанавливать сам компонент: com_kunena_v2.0.4_2013-01-18.zip

Процесс установки для Kunena 2.0 похож на процесс установки который использовался в более ранних версиях.

Обновление предыдущих версий 1.6 и 1.7.x до новой версии Кунена 2.0

При обновлении тоже нет ничего сложного, важно отметить только то, что вам не нежно удалять вашу версию Kunena для обновления до новой версии.

Сам процесс обновления происходит автоматически и сохраняет все ваши существующие настройки форума, а также и все остальное: категорий, определенных вами Модераторов форума, все данные пользователей, темы, сообщения, и так далее, в общем все, что было создано в предыдущей версии Kunena останется, за исключением каких либо изменений в коде Кунена.

И еще один момент, так как Кунена 2.0 не совместима с подключаемыми модулями и другими расширениями, разработанными для предыдущих версий Кунена, рекомендуется их отключить перед установкой или обновлением.

Процесс установки Kunena 2.0 завершится неудачей, если ваша система не соответствуют минимальным системным требованиям.
Никогда не выполняйте установку или обновление без
полного резервного копирования!

Версия Joomla: 1.5, 1.7, 2.5
Внимание!
Для просмотра скрытого текста, Вам необходимо Войти или Зарегистрироваться.
  • Joomla компоненты
  • 9-06-2013, 22:26
  • 2243
Вернуться назад
Информация
Посетители, находящиеся в группе Гости, не могут оставлять комментарии к данной публикации.