WordPress 3.7

0
WordPress 3.7

Новая версия WordPress 3.7 “Бейси”, названа в честь джазового музыканта Каунта Бэйси и нацелена на стабильность и безопасность вашего сайта.
Основные нововведения в WordPress 3.7: автоматические обновления, языковые пакеты, безопасные пароли.

Автоматические обновления в 3.7

В новой версии WordPress можно забыть про технические обновления ядра, поскольку они будут выполняться автоматически, а отчёт о подобном обновлении придёт вам на электронную почту. В случае сбоев при обновлении (например нехватка места на жёстком диске, обрыв соединения или сбой при копировании файлов) WordPress теперь сможет откатить обновление самостоятельно.

WordPress 3.7


Учтите, что для успешной работы автоматических обновлений, права на запись и замену файлов ядра должны быть корректно настроены на вашей хостинг-площадке. В случае если WordPress не сможет выполнить обновление автоматически, администратор сайта получит уведомление по электронной почте.

Так же важно отметить, что по умолчанию обновления происходят только на технические релизы. Это означает, что обновление с версии 3.7 на 3.7.1 и на 3.7.2 произойдёт автоматически, а обновление до версии 3.8 нужно выполнять самостоятельно. Конечно же это легко изменить с помощью простого фильтра в плагине:
add_filter( 'allow_major_auto_core_updates', '__return_true' );

Вы можете так же отключить автоматические обновления с помощью фильтра:
add_filter( 'auto_update_core', '__return_false' );

По умолчанию WordPress 3.7 не будет автоматически обновлять темы и плагины, но и это можно изменить с помощью фильтров auto_update_theme и auto_update_plugin соответственно.

Локализация и переводы

В новой версии ядра произошли так же изменения в механизме локализации и языковых пакетов. WordPress теперь будет автоматически обновлять языковые пакеты для ядра и стандартных тем оформления. Это значит, что нет необходимости больше ждать выхода локализованной версии ядра — вы можете обновиться уже сейчас, а языковые пакеты для вашего языка обновятся тогда, когда они будут готовы.

В будущем этот функционал планируется расширить до сторонних тем и плагинов WordPress.

Слабые пароли

В WordPress 3.7 появилась библиотека zxcvbn от Dropbox, которая обеспечивает улучшенный индикатор надёжности паролей, опираясь не только на количество символов, но и на само содержание. Например 1234567890, password, qwerty и даже h3ll0w0r1d теперь помечаются как “очень слабые пароли”.

WordPress 3.7

Внимание!
Для просмотра скрытого текста, Вам необходимо Войти или Зарегистрироваться.
  • WordPress релизы
  • 26-10-2013, 12:46
  • 1205
Вернуться назад
Информация
Посетители, находящиеся в группе Гости, не могут оставлять комментарии к данной публикации.